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RAMMS CHANGELOG 

V 1.8.26 [2024-07-01] 

GENERAL 

• Improvement: Bat-Files: Up until now, when starting a simulation, RAMMS 

created a bat-file, and then started this bat-file. This could create 

problems because of Windows-access-privileges. Resolved! RAMMS does not use 

bat-files any more to start a simulation. 

• Improvement: Export ASCII/TIFF files: Also Max Momentum and Max Shear Stress 

(for DBF) are exported automatically after a simulation. 

• Improvement: Batch Mode: Small bugs resolved in batch mode. 

V 1.8.0 [2022-10-26] 

GENERAL 

• New Feature: Parallelization: With this new update, the computational core 

of RAMMS uses OpenMP parallelization (CPU). This is especially important for 

debris flow simulations, where the grid resolution is normally more accurate 

(in the order of 1-2m) than for avalanche simulations (5-10m). We also 

slightly improved the numerics, yielding improved results in channelized 

flow regions. 

 

• New Feature: Recent Files: RAMMS stores up to 10 of your most recent input- 

or output-files, such that you can open and find them easier. You can find 

this feature in the menu “Track -> Recent…”. 
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• New Feature: Export results to TIFF-raster: RAMMS could only export results 

to ASCII grid raster files (GIS → Export… → Result as Raster Data). NEW: 

the default export format is GEOTIFF! If you want to export ASCII raster 

files, then you can set the OUTPUT_GRID_FORMAT keyword in the Add. 

Preferences: 

 

OUTPUT_GRID_FORMAT ASCII (ASCII or GEOTIFF) 

 

Then click Save and OK. 

 

• New Feature: Time Annotation in Main Window: When animating, a text shows 

the elapsed time in seconds.  

 

 

 

 

• New Feature: DEM Contour Lines: Contour lines of the DEM can be visualized 

(GIS → Show Contour Plot). 
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• New Feature: Simulation Contour Lines: Contour lines of simulation results 

can be visualized. 

 

 

 

Default contour levels are: 

- Flowheight (m):  1.0 2.0 3.0 5.0 10.0 (H_CONTOUR_LEVELS) 

- Velocity (m/s): 1.0 5.0 10.0 20.0 30.0 40.0 50.0 (V_CONTOUR_LEVELS) 

- Pressure (kPa):  1.0 3.0 10.0 30.0 100.0 (P_CONTOUR_LEVELS) 

 

You can change these contour levels by adding the following lines in the 

Add. Preferences (before the END tag): 

 

Example: 

H_CONTOUR_LEVELS 0.5 1.0 1.5 2.0 

V_CONTOUR_LEVELS 5.0 10.0 50.0 

P_CONTOUR_LEVELS 3.0 10.0 30.0 

 



 
v1.1 – June 2024 

 

 

 

© RAMMS AG 2024 

Then click Save and OK, and then draw new contour lines. 

 

• New Feature: Dump Step Button: A new button  was added to the horizontal 

toolbar to easily switch between DumpStep- and Max-Values. To animate your 

simulation, it is necessary to look at DumpStep-Values. 

 

 

 

• Improvement: Colorbar: The handling of the colorbar has slightly changed. 

Until now, the lowest color band was transparent, resulting in values not 

being shown. The new colorbar will now show all the values, even very small 

ones. If you do not want to see very small values, then you have to set the 

colorbar MIN value! 

 

Old Appearance 

 

 

New Appearance 

 

 

Transparency can be moved with a slider. 

New simulation contour lines. 

 

Comparison of old (left) and new (right) colorbar handling (same simulation): 
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    Values < 0.1 are not displayed           All values are displayed 

If you want to reproduce the same visual result with the new colorbar, you would 

have to set the Min-Value to 0.1 in the above right example. 

 

 

 

 

• Improvement: Convert irregular XYZ point file to raster: Only regular XYZ 

data could be converted to an ASCII raster in RAMMS. NEW: Irregular XYZ 

points can be converted (LINEAR or INVERSE DISTANCE interpolation methods 

available) to a raster (GEOTIFF or ASCII).  

Track → New… → Convert XYZ Data to Raster Data 

 

• New Feature: Hillshade Visualization: Use “Extras → Create Hillshade Image” 

to create a hillshade image of your DEM. 

 

Visualization of DEM Surface  
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Visualization of hillshade image 
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New Feature: Multiple ASCII- or TIFF-File Export: Export an ASCII- or TIFF-file for 

every dump step. This option can be set in “Help -> Advanced… -> Additional 

Preferences… -> Edit”. Add the following line (before the END tag, see figure 

below): 

 

ANIMATE_OUTPUT_GRID  1 

 

Then click Save and OK, and start animating. 

 

 

 

 

• Improvement: Google Earth: Improved. Only Swiss-, UTM- and StatePlane-

coordinate systems available. 

 

• New Feature: New Stopping Criterion – Center of Mass Velocity: The idea of 

this new stopping criterion is the following: We follow the center-of-mass 

(COM) of the flow. We do a new calculation of the COM every 5s for debris 

flows, and every 2s for avalanches (because they move faster), and then 

calculate the velocity, with which the COM is moving. 

The user can define a velocity threshold (in m/s), and as soon as the COM is 

moving slower than the threshold, RAMMS considers the flow as stopped.  

This criterion should only be used, if you simulate one single debris flow 

problem (catchment). If you define two or more block-releases (for different 

catchments), then this approach makes no sense. In this case, set the 

threshold value to zero. 
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V 1.7.20 [2018-07-11] 

GENERAL 

• Bugfix: Line Profile: Resolved a small bug concerning the line profile. Line 

profile plots and discharge values are more accurate now. 

• Bugfix: Overlapping release areas: Resolved a bug with overlapping release 

areas. 

DEBRIS FLOW 

• Bugfix: Subtract release depth from DEM: RAMMS crashed when trying to use 

the “Subtract release depth from DEM” option with a block release, and 

NoData values were present in the DEM. Resolved. 

• New Feature: Max Erosion ASCII file: After a successful simulation, RAMMS 

will automatically export the “Max Erosion” ASCII file. 

 

 

V 1.7.15 [2018-03-30] 

• Bugfix: Colorbar and Plot problem: Finally, we realized that this is an IDL 

problem with Windows 10. Many users complained about not seeing numbers and 

text from colorbars and plots. 

 

 

 

You can fix this by running RAMMS in ”Windows 7 Compatibility Mode”. Please 

do the following: 

 

- Exit RAMMS 

- open Windows Explorer and navigate to your RAMMS installation folder. 

- right-click on RAMMS.exe 

- choose the tab Compatibility 

- select the checkbox ”Run this program in compatibility mode for:”  
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- choose Windows 7 from the dropdown menu 

- and then click Apply and OK. 

- Restart RAMMS. All your plots and colorbars should be ok now. 

 

 

 

• Bugfix: Slope/curvature/contour in output mode: There was a small bug when 

looking at slope/curvature/contour plots in output mode and changing min and 

max values. Resolved. 

• Bugfix: Register New Module: Small bug when creating a new license request 

file. Resolved. 
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V 1.7.10 [2018-03-06] 

GENERAL 

• Bugfix: Colorbar and Plot problem: The colorbar and plot problem from the 

updates below was investigated further.  

 

 

If you still have these problems with the new update, then add the following 

line(s) to the ‘Additional Preferences’ (Button  ): 

FONTNAME Hershey 3 (you can use any font-name installed on your system) 

 

you can also change the text size of the plots: 

FONTSIZE 12  (increase or decrease the number as you like) 

 

or the size of the colorbar text: 

CB_FONTSIZE 12  

  

• Bugfix: Server installation: When installing RAMMS on a server, where only 

one at a time can use RAMMS, RAMMS got locked by the first user. Even if 

this user closed RAMMS and logged off, no other user could use RAMMS. 

Resolved. 

• Bugfix: x64 high resolution problem: When trying to simulate a very large 

problem (high resolution DEM), and using the x64 option in ‘Additional 

Preferences’, RAMMS crashed anyway. Resolved.  

 

It’s recommended to use the X64-Option in the ‘Additional Preferences’: 

X64 1   

 

Remark: Using very high resolution DEM’s can lead to very large simulation 

times and very high disk memory usage. It’s important to use very narrow and 

small calculation domains to reduce the scenario size. See ‘Calculation 

Domain’ in the manual on how to get an ideal calculation domain. 

 

• New Feature: Simulation with only MAX VALUES saved: Simulations with a high 

resolution DEM can lead to a high amount of used disk space. If you want to 

save disk space and if the max values are all you are interested in, then 

use this feature. 
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Additional remarks: 

- after a simulation finished, all ASCII files (deposition, max flowheight, 

max velocity and max pressure) are exported automatically. 

- the simulation results cannot be visualized in RAMMS (at the moment). 

 

Click this checkbox to save only Max Values! 

 

DOS-Output-Window: The numbers indicate the simulation time. 

• New Feature: Overlapping release areas: Do you have overlapping release 

areas, and are not able to select the underlying release area? Use ”Input → 

Release Area… → Details/Edit Overlapping Release Areas”. 

 

AVALANCHE 

• Bugfix: Volume category suggestion: When creating a new MuXi-File, RAMMS did 

not suggest a volume category anymore. Resolved. 
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V 1.7.05 [2017-12-19] 

GENERAL 

• Bugfix: Enter Coordinates (X/Y): Using the menu ”Extras → Point… → Enter 

Coordinates (X/Y)”, RAMMS did not create a Time Plot. Resolved. 

• Bugfix: Export Result as Shapefile: Using the menu ”GIS → Export… → Result 

as Shapefile” for max velocity, RAMMS produced the following error message 

and crashed. Resolved. 

 

 

• Bugfix: Colorbar problem: The colorbar problem from the update below also 

produced bad Time- and Profile-Plots.  

 

 

You can overcome this problem by adding the following line to the 

‘Additional Preferences’: 

 

PLOT_FONT_NAME Hershey 3 

V 1.7.03 [2017-12-12] 

GENERAL 

• New Feature: Import release depths from attributes. After the last update, 

release depths could not be imported from shapefiles anymore, sorry about 

that! You can do this now by right-clicking a shapefile in the Files-Tree in 

the panel. You can then choose an attribute to import. 
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• Bugfix: Using the menu ”Input → Polygon Shapefile… → Load Existing Polygon 

Shapefile” RAMMS produced this warning message, with RAMMS crashing. 

Resolved. 

 

• Bugfix: Using ”Add files from external directory” (Files-Tree ) RAMMS 

produced this warning message, with RAMMS crashing. Resolved. 

 

• Bugfix: Very seldom a problem occurred with the colorbar, see white boxes 

below, making it impossible to read the colorbar tick text. Resolved. 
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DEBRIS FLOW 

• Bugfix: ”Help → Manual” would open the Avalanche Manual. Resolved. 

 

 

V 1.7.0 [2017-11-29] 

DEBRIS FLOW 

• New Feature: Erosion → see manual for more details. 

• New Feature: Calculation of flow discharge for a line profile. 

AVALANCHE 

• New Feature: Secondary avalanche release → see manual for more details. 

GENERAL 

• New Feature: New file handling. Multiple shapefiles can be visualized at 

once. Properties (color, line style and size) can be set separately. More 

than one polygon shapefile can be used as release shapefile. No need anymore 

to convert GIS shapefiles to RAMMS release or domain shapefiles. 

• New Feature: 64-bit calculation core. RAMMS will not crash anymore with very 

large project regions. The calculation core can be set to 64-bit in the 

additional preferences (default: 32-bit, faster than 64-bit). 

• New Feature: Create envelope shapefile from simulation results or ASCII 

files. This feature can be used to create optimized calculation domain 

shapefiles (saving tremendously calculation time, especially with debris 

flows). 

• Improvement: Batch-Mode improved. 

• Improvement: Simulations can be cancelled (both avalanche and debris flow 

simulations)!!! Close the simulation-DOS-window (see below)  
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and RAMMS will stop the simulation and open the simulation up to the 

calculated time.  

• Improvement: Cohesion and Curvature controls added to the ‘Params’ Tab in 

the ‘Run Simulation’ window.  

• Improvement: Export to Google Earth options improved. 

• Improvement: The new numerical scheme uses a different Hcutoff since Version 

1.6.20. If you open an old input file with an old Hcutoff value, RAMMS 

advises the user to change the Hcutoff value. 

• Bugfix: When running parallel simulations (more than one RAMMS program 

open), the first finished simulation also closed the other simulation 

progress windows. Resolved. 

• Bugfix: When overwriting an existing project, the old project was not 

completely deleted. This could lead to unexpected bugs, when creating a 

different project with the same name. Resolved. 

• Bugfix: Unchecking ‘Edit→Show Dataspace Axes’ did not remove the Z-Axis. 

Resolved. 

• Bugfix: Changing the background color in the Preferences did not work. 

Resolved. 

• Bugfix: Some small bugs resolved (checking pointer validity, memory, etc.). 

• Bugfix: In some cases, Batch Simulations failed due to a small bug in the 

Save-Routine of RAMMS. Resolved.   

 

 

V 1.6.40 [2015-04-17] 

ROCKFALL 

• Official release of RAMMS::ROCKFALL Module 

• Web page at http://ramms.slf.ch 

• Email: ramms@slf.ch 

 

http://ramms.slf.ch/
mailto:ramms@slf.ch
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V 1.6.20 [2014-03-05] 

GENERAL 

• Bugfix: ‘Install Update from local folder’ did not work. Resolved. 

• Bugfix: ‘AutoWebUpdate’ would not have detected 64-bit processors, updated 

software would have worked as 32-bit version. Resolved. 

• Bugfix: Colortable-Nr of colorbar can be changed interactively. Did not work 

before. With 'Help → Advanced... → Color Tables... → View Color Tables' 

the available colortables (with index number) can be viewed and with 'Help → 

Advanced... → Additional Preferences... → Edit' the colortable can be 

changed (set COLORTABLENR to the corresponding index number, click Save and 

OK). 

• Improvement: Memory management generally improved. E.g. before starting a 

simulation, RAMMS closes the input file. RAMMS then uses less memory. 

• Improvement: IDL version updated to 8.2.3. 

• Improvement: New Time Plots and Line Profile Plots. 

• Improvement: Summary of Moving Mass shows new plots and tables to analyse 

the mass flow. 

• Improvement: Automatic export of ASCII files after a simulation of: Max flow 

height, max velocity, max pressure and deposition (last dump step). 

• New Feature: Generation of ASCII files (max flow height, max velocity, max 

pressure and deposition) from multiple output files. 

• New Feature: Visualizations can now be deleted from view (file tree in the 

left panel), Remove Visualization Button . 

• New Feature: Draw New Polygon Shapefile; normal polygon shapefiles can be 

plotted (use this button  in the upper horizontal toolbar). 

• New Feature: The velocity direction vector can now be plotted as an arrow 

(use this button  in the left vertical toolbar). Arrows will change in size 

and lengths when zooming into the visualization. The appearance of the arrow 

can be changed in the ‘Additional Preferences’ (ARROW_COLOR, ARROW_FACTOR, 

ARROW_HEADSIZE, ARROW_LENGTHSCALE, ARROW_THICK). 

• New Feature: Improved numerical scheme. Small numerical instabilities in 

very steep terrain are corrected with the improved numerical scheme. Mass 

loss is minimized due to a lower Hcutoff. Default Hcutoff = 0.000001m. 

• New Feature: Cohesion implemented. The basic Voellmy friction equation has 

been modified to include cohesion. It increases the shear stress and 

therefore causes the avalanche or debris flow to stop earlier, depending on 

the value of the cohesion. 

• New Feature: Obstacle/Dam feature implemented. Draw polygons of areas, where 

no avalanche or debris flow should pass (houses, deflecting dams, 

obstacles). The flow is deflected. 

• New Feature: Curvature is taken into account in the frictional model. The 

normal force N now includes centrifugal forces arising from the terrain 

curvature. Typically this increases the friction, causing the flow to slow 

down in tortuous and twisted flow paths. 

• New Feature: RAMMS::Viewer available now! With the viewer, you can look at 

your RAMMS simulations even if your license expired! You are not able to do 

new simulations. 
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• New Feature: ‘GIS → Convert Polygon Shapefile… → to RAMMS Domain 

Shapefile’. 

• New Feature: Button ‘Colorbar Properties’ changed to ‘Additional 

Preferences’. 

• New Feature: Shapefile color can be changed in the ‘Additional Preferences’ 

(SHAPEFILE_COLOR). 

DEBRIS FLOW 

• Improvement: Hydrograph improved: Capturing of improper input and numerical 

implementation of hydrograph improved. 

 

V 1.5.01 [2012-12-13] 

GENERAL 

• Bugfix: When changing the background color in the preferences, RAMMS did not 

save this position. Fixed.  

• Bugfix: The vertices of polygon shapefiles were written in both clockwise 

and counter-clockwise order, depending on how the user clicked the points. 

ArcGIS is having problems to work with counter-clockwise polygon shapefiles. 

Polygon shapefiles are therefore written only in clockwise-order. 

• Bugfix: ‘Help → Advanced… → Hardware Rendering’ did not work. Fixed. 

• Bugfix: ‘Help → Advanced… → Install C++ Libraries’ did not work. Fixed. 

• Improvement: When changing the background color to white, the axes of the 

project region are still visible, and the text of the colorbar is also 

white. The axes can be disabled and enabled (‘Edit → Show Dataspace Axes’), 

and the text-color of the colorbar can be switched between white and black 

(‘Edit → Colorbar White Color’). 

 

V 1.5.0 [2012-11-27] 

GENERAL 

• Bugfix: Bug found in the license procedure. When a user entered a wrong 

license key, the license was saved anyway, and RAMMS then could not be 

started anymore. Resolved. 

• Bugfix: Negative coordinates did not work anymore in version 1.4.14. 

Resolved. 

• Bugfix: Bug found in the MuXi-classification with a forest cover, if DEM 

resolution was equal to 10m. RAMMS could not complete the classification and 

showed an Error Message. Resolved. 

• Bugfix: Bug resolved when converting a shapefile to a RAMMS release 

shapefile. 
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• Bugfix: Bug found in the GIF-Animation procedure. Two GIF-Animations could 

not be generated one after the other, because the first file was not closed. 

Resolved. 

• Bugfix: Until now, coordinates were saved as float-values. With high 

resolution DEM’s, this could lead to a loss of accuracy (in the range of 

0.1m). Coordinates are now saved as double values. 

• Improvement: 64-bit Support! If you have a 64-bit computer (Windows 7), 

please uninstall your current RAMMS version, download the new 64-bit version 

from ramms.slf.ch and install it. Your old license key will still work with 

the new 64-bit version. The 64-bit Version will solve many memory problems, 

because more dynamic memory can be allocated. 

• Improvement: Updated from IDL 7.1 to IDL 8.2.1.  

• Improvement: The Map/Orthophoto procedure was improved. RAMMS now finds also 

maps/orthophotos, that cover the project region only partially! RAMMS also 

shows a percentage of coverage. 

• Improvement: Zoom level resets to 100% when closing an input- or output-

file. 

• Improvement: RAMMS issues a warning message, if the user tries to draw a 

release area or a calculation domain in 3D-mode. 

• Improvement: Version 1.5 introduces a new RAMMS application user directory. 

Prior to version 1.5, the application directory was located here: 

‘C:\Documents and Settings\<user name>\.ramms1.X.X’ (Win XP) or  

‘C:\Users\<user name>\.ramms1.X.X’ (Win 7) 

For every new version of RAMMS, a new application directory was created, and 

the old one was copied into the new one, occupying a lot of disk space.  

The new application directory is created only once and is located here: 

‘C:\Documents and Settings\<user name>\.idl\slf\ramms’ (Win XP) or 

‘C:\Users\<user name>\.idl\slf\ramms’ (Win 7). 

• New Feature: Outflow-Volume-Alert – RAMMS alerts the user, if volume is 

flowing out of the calculation domain. 

• New Feature: Annotation-Buttons in the horizontal toolbar can be deactivated 

(and activated). 

• New Feature: New buttons were implemented in the horizontal toolbar (to the 

right side) – MuXi-File, Slope Angle, Curvature, Contour, Max Flowheight, 

Max Velocity, Max Pressure, Time Plot, Export ASCII, Show Project Folder, 

Add/Change Map/Orthophoto. 

 

 
 

• New Feature: RAMMS About Box (‘Help → About RAMMS’) shows whether you are 

using the 32- or the 64-bit RAMMS version. 

• New Feature: Quasi 3D-Visualization of flow height implemented. The flow 

height can be visualized exaggerated by a factor. This factor can be changed 

in ‘Help → Advanced… → Additional Preferences… → Edit’, keyword 

EXAGGERATION. 

• New Feature: Batch-Mode -> Possibility to start up to 50 simulations 

automatically (e.g. over night). Users can choose, how many computational 

cores the Batch-Mode should use (quasi parallel simulations, saves 

computational time!). ‘Track → New… → Run BATCH simulations’ 

• New Feature: Import one (1) attribute from polygon shapefiles (e.g. release 

depth) when converting them to a RAMMS release shapefile. 



 
v1.1 – June 2024 

 

 

 

© RAMMS AG 2024 

• New Feature: Colorbar can be moved anywhere in the screen (Attention, 

colorbar can get lost now! ☺ ). Use ‘Project → Get Colorbar’ to find a lost 

colorbar. 

• New Feature: Open Project Folder in Windows Explorer from within RAMMS. Use 

the appropriate toolbar button  in the horizontal toolbar or ‘Project → 

Open Project Folder (Windows Explorer)’. 

• New Feature: Polyline Shapefiles can be visualized in RAMMS. 

• New Feature: User can choose between the operating system’s native 

(hardware) rendering system or a platform independent (software) rendering 

system for IDL Object Graphics displays. Hardware rendering allows IDL to 

make use of 3D graphics accelerators that support OpenGL, if any are 

installed in the system. In general, such accelerators will provide better 

rendering performance for many object graphics displays. This is typically 

true for images rendered using texture-mapped polygons (typical for RAMMS). 

Anyway, there are situations, where it can be better to use software 

rendering. Hardware rendering can be switched off (and software rendering 

switched on) by unchecking ‘Help → Advanced… → Hardware Rendering’. 

• New Feature: Resetting General Preferences. Use ‘Help → Advanced… → Reset 

General Preferences’ to reset the General Preferences.  

• New Feature: View Google Earth Map Projection Options with ‘Extras → Google 

Earth… → Map Options Help’. 

 

DEBRIS FLOW 

• New Feature: Define Additional MuXi Areas → Users can add polygon regions 

with different mu and xi values (Run → Run Calculation: Mu/Xi Tab). Be 

careful in using this feature! 

 

V 1.4.14 [2011-11-24] 

GENERAL 

• Bugfix: An error could happen when RAMMS tried to grid the simulation data. 

This only happened with small grid resolutions. Resolved. 

• Improvement: File tree improved in the right panel. 

• New Feature: Reading DEM-files: RAMMS accepts ‘xllcenter/yllcenter’ keywords 

in ASCII-grid files (until now, RAMMS only accepted ‘xllcorner/yllcorner’). 

• New Feature: AutoWebUpdate. When you start RAMMS, it will automatically 

check for updates on the internet. This could lead to an Error-Message, if 

your firewall blocks the executable ‘idlrt.exe’ (this file starts the IDL-

Virtual Machine you need to run RAMMS). Please unblock this file for your 

firewall. You can also disable the AutoWebUpdate-Function by unchecking 

‘Help → Advanced… → AutoWebUpdate’. The WebUpdate-Function can still be 

done manually (‘Help → Update… → Web Update’ or ‘Get Update Manually 

(download to local folder)’). 

• New Feature: Logging. By default, RAMMS writes status messages in a log 

file. You can access this file with ‘Track → Log Files… → RAMMS Log File 
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(current session) or (last session)’. The ‘(last session)’ log file can be 

useful in case of a crash. You can disable the Logging-Function by 

unchecking ‘Help → Advanced… → Logging’ (this could result in a slightly 

faster execution of RAMMS, but only slightly). 

AVALANCHE 

• Bugfix: MuXi error: When the MuXi file was selected in the ‘Run Simulation’-

window (with the ‘Select MuXi File…’ button, see picture below), instead of 

selecting the MuXi file with ‘Input → Friction Values… → Load Existing MuXi 

File’, the following happened: 

o the selected MuXi name was correctly displayed in the text field on 

the left of the button 

o the output log file showed the selected MuXi file 

o BUT, RAMMS did not calculate with the selected MuXi File, but used 

the ‘old’, previously selected MuXi file instead. If you frequently 

used the button in the picture below, you should check your 

simulations. Otherwise, you do not have to do anything. 

 

This bug is resolved! MuXi files can be selected with ‘Input → Friction 

Values… → Load Existing MuXi File’ or in the ‘Run Simulation’-window with 

the button ‘Select MuXi File…’ (see picture above). 
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V 1.4.10 [2011-09-07] 

GENERAL 

• Bugfix: An error occurred when trying to crop release areas and then cancel 

the process instead of entering a new name. Resolved. 

• Bugfix: Several button-tooltips did not work. Resolved. 

• Improvement: When working with large TIFF files, the available memory is 

checked, and a message appears, if not enough memory is available 

• New Feature: New RAMMS Modules can be registered directly in RAMMS (‘Help → 

Register New RAMMS Module’). 

AVALANCHE 

• Bugfix: An error occurred when trying to re-calculate an old project with 

old MuXi files (Shapefile-type). This error is resolved. 

• Bugfix: An error occurred when trying to calculate a new MuXi file with a 

grid resolution of 10m. This error is resolved. 

• Improvement: Create New MuXi File: The Global Parameters Window is 

automatically shown when creating a new MuXi file. 

DEBRIS FLOW 

• Official release of RAMMS::Debris Flow Module 

• Web page at http://ramms.slf.ch 

• Email: ramms@slf.ch 

 

V 1.4.07 [2011-08-09] 

Cygwin/GRASS has been removed from the RAMMS software package. RAMMS does not 

use Cygwin/GRASS anymore. Due to major problems on Windows 7 we decided to 

remove Cygwin/GRASS. Therefore major changes were made in this RAMMS version, 

see below. 

• Installation: You can install RAMMS wherever you want now. ‘C:\Program 

Files\RAMMS’ is possible. BUT, ‘blancs’ and ‘special characters’ are still 

not allowed in project names and working directories. 

• New Project: The creation of a new project is significantly faster without 

Cygwin/GRASS! 

• MuXi-Files: The automatic classification of mu and xi is more accurate and 

MUCH FASTER now. Due to the improved classification procedure, the result of 

a muxi-classification is not exactly the same as in the earlier version. 

Fortunately, the differences are very small and therefore not significant 

for simulation results.  

http://ramms.slf.ch/
mailto:ramms@slf.ch
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• MuXi-Files: The muxi-values are saved as ASCII-files, and not as shapefiles 

anymore. However, old muxi-shapefiles can still be imported, visualized and 

simulated.  

• MuXi-Files: MuXi-Values are only visualized within the calculation domain! 

 

Some other new features and improvements: 

 

• New Feature: File-Tree available in the right Avalanche panel. Release-, 

MuXi-, Forest-, Calculation Domain- and Shapefile-Files within the project 

directory are listed in the file-tree. Select any file and it will be 

displayed immediately.  

• New Feature: Run a simulation in the background. Simulations can be run in 

the background, you can continue to prepare a new simulation and start more 

simulations simultaneously.  

• New Feature: Jump directly from a simulation to the corresponding input 

file. A new button has been added to the vertical toolbar:  

• New Feature: Zoom with mouse wheel.  

• Improvement: Handling of maps and orthophotos is improved. RAMMS does not 

crop maps/orthophotos anymore and you don’t have to save these cropped 

maps/orthophotos all the time. RAMMS uses always the same original file for 

the visualization.  

• Improvement: Error handling improved. RAMMS should crash less. In case of an 

error, RAMMS shows an Error-Windows, but RAMMS does not crash anymore. If 

you experience a crash, please report the circumstances to ramms@slf.ch! 

• Bugfix: It happened that the settings in the Global Parameters were not 

accounted for correctly when calculating a MuXi-file. This bug is corrected. 

• Bugfix: Some MuXi-values for Tiny-10year were missing in the Automatic MuXi 

Procedure window. This bug is corrected. 

 

V 1.3.16 [2010-11-11] 

• New Feature: Drawing of lines and polygons (Line-Profile; Release-, Domain- 

and Forest-Polygons) changed. Problems of closing the lines and polygons 

with a double-click were reported. Lines and Polygons are to be closed now 

with a RIGHT MOUSE CLICK. 

• New Feature: Raster information available! Until now, the raster information 

used in GRASS was available in the GIS/GRASS logfiles. To make it easier to 

check whether FOREST and DEM raster information is available, this 

information can be viewed in the 'Project'-menu. 

• New Feature: Colors of the Colorbar can be changed! With 'Help -> 

Advanced... -> Color Tables... -> View Color Tables' the available Color 

Tables can be viewed and with 'Help -> Advanced... -> Additional 

Preferences... -> Edit' the Color Table can be changed. 

• New Feature: Map/Orthophoto-Selection-Window enlarged. The width of the 

window can be set in the 'Additional Preferences'. 

• New Feature: RAMMS informs one week before expiration of the license. The 

expiration date can be looked at in 'Help -> About RAMMS'. 

• Improvement: Grid resampling improved. Until now, every grid was resampled, 

even if the calculation resolution matched the DEM resolution. Matching 
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resolutions are not resampled anymore. Simulations can now be performed on 

exactly the input DEM! 

• Improvement: Estimation of release volume improved. With matching 

calculation / DEM resolutions (see above) the estimation of the release 

volume is improved significantly. 

• Improvement: Conversion of Polygon Shapefiles to RAMMS Forest Shapefile 

improved. 

• Improvement: The routine to produce a GIF-Animation was improved. The delay 

of the images within a GIF-Animation can be controlled by the parameter 

'GIFANIM_DELAY_TIME' in the 'Additional Preferences', see above. The value 

represents the delay in hundredths (1/100) of a second. 

• Bugfix: 'Commas' as decimal points or changed order of header lines in ASCII 

DEM files resulted in a program crash. This bug is resolved. 

 

V 1.3.08 [2010-08-19] 

• Bugfix: A small error was found when dealing with FORESTED areas below 

'Altitude Limit 1' (in Switzerland below 1500 m.a.s.l.). It's possible that 

too high values of 'mu' are used for the forested areas in the MuXi-file. 

 

V 1.3.05 [2010-03-23] 

• Improvement: Improved memory management, RAMMS uses less memory now. 

• Improvement: Colorbar handling improved. The colorbar changed size when 

zooming. This was very annoying. Resolved. Font size and font type can be 

changed now. 

• Improvement: Export image feature improved: Only GIF and TIFF images could 

be exported until now. New file types: .bmp, .jpg, .pict, .jp2 

• New Feature: 30-day Demo Version available. See http://ramms.slf.ch. 

 

V 1.3.0 [2010-03-01] 

• Official release of RAMMS::Avalanche Module 

• Web page at http://ramms.slf.ch 

• Email: ramms@slf.ch 
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